• ¡Bienvenido a XenFácil!

    Estás viendo el sitio como Invitado. Para poder participar en este sitio

    y obtendrás privilegios adicionales, acceso a otras áreas y mucho mas.

    ¡Es gratis!


    ¿Ya eres miembro? Inicia sesión

Solucionado Duda con index.

Estado
Cerrado para nuevas respuestas

lenin

XenForoUser
Mensajes
451
Puntuación de reacciones
212
Puntos
43
Sitio web
kpumco.com
País
El Salvador
Versión de XenForo
bueno, yo tengo una duda..

el chiste es el siguiente:
instale XF en el root por lo tanto es misitio.com pero quiero
hacer un index en html, que por logica cuando se escriba en el navegador misitio.com redirigira al
index en html, el cual es un problema por el index de xf no se le puede cambiar nombre al php
por que da error..
antes de instalar el XF pense hacerlo en un directorio foro, pero luego me dije que no lo necesitaria, pero hoy quiero hacer otras cosas. y tengo ese problema.
por que no creo que se pueda mover la instalacion de carpeta o si?
le pregunta es: habra alguna manera de tener el index html y el php en la misma carpeta via .htacces?
se accederia de la siguiente manera
misitio.com<------- ese seria con el index html
y
misitio.com/index.php<--- obvio con index.php
claro que para el foro tendria que modificar el navbar de inicio y foro, pero eso es lo de menos.

pero si se puede mover a una carpeta son hacer instalacion nueva.. seria mejor
 

lms

Administrador
Mensajes
7.669
Puntuación de reacciones
2.098
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Ambos ficheros son compatibles en servidores linux y pueden estar juntos en la misma carpeta sin ningún problema. El que abra una u otra lo puedes configurar en tu cPanel. Quién teclee la ruta de tu dominio.com sólo, entrará al index.html en el cual puedes poner una redirección, un botón o algo para que los puedas enviar al .php (siempre se podrá acceder tecleando la extensión php como ruta -index.php -). En el foro configuras URL de la página de inicio el .php y como URL del sitio el dominio.com, deselecciona Enlace del logotipo a la URL de la página de inicio si quieres que vaya al índice del foro el enlace del logotipo o la dejas marcada si quieres que vaya al .html.

Salud2
 

lms

Administrador
Mensajes
7.669
Puntuación de reacciones
2.098
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Si quieres pasar el foro a un directorio (por ejemplo, foro) entra en el panel de control -> Inicio -> Opciones -> Información básica del sitio -> URL del sitio -> por la ruta http://www.tudominio.com/foro y guarda los cambios.
Mueve todo el contenido a la carpeta foro y comprueba que rula bien. Con un buen cliente de FTP (coomo Directory Opus que es un buenísimo emulador del explorer de windows pero muuuuuuuuucho más aventajado y, para mi, el mejor cliente de FTP) es cuestión de un par de minutos el hacerlo. Eso sí, las urls al propio sitio dejarán de funcionar (si has puesto en un mensaje "te respondí en este tema http://www.tudominio.com/duda-con-index.168/#post-1008" te dejará de funcionar.)

Salud2
 

lenin

XenForoUser
Mensajes
451
Puntuación de reacciones
212
Puntos
43
Sitio web
kpumco.com
País
El Salvador
Versión de XenForo
Si quieres pasar el foro a un directorio (por ejemplo, foro) entra en el panel de control -> Inicio -> Opciones -> Información básica del sitio -> URL del sitio -> por la ruta http://www.tudominio.com/foro y guarda los cambios.
Mueve todo el contenido a la carpeta f......
Salud2
bueno hise eso pero me dio error cuando moví los archivos de lugar... ...
 

lms

Administrador
Mensajes
7.669
Puntuación de reacciones
2.098
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Caché, maldita caché.

Salud2
 

lenin

XenForoUser
Mensajes
451
Puntuación de reacciones
212
Puntos
43
Sitio web
kpumco.com
País
El Salvador
Versión de XenForo
entonces lo hago asi y me toca esperar cierto ....
 

lms

Administrador
Mensajes
7.669
Puntuación de reacciones
2.098
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Logueate en el panel de control (http://www.tudominio.com/foro/admin.php) -> Herramientas -> Reconstruir cachés.

Así debiera de funcionarte de nuevo el foro.

Salud2
 

lms

Administrador
Mensajes
7.669
Puntuación de reacciones
2.098
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
devuelve los archivos a la carpeta inicial. Logueate en el panel e control y reconstruye caches. devuelve los archivos a la carpeta foro.

Debiera de funcionar. Estoy tentado de hacerlo yo mismo y ver como.

Salud2
 

lenin

XenForoUser
Mensajes
451
Puntuación de reacciones
212
Puntos
43
Sitio web
kpumco.com
País
El Salvador
Versión de XenForo
bueno eso q me has dicho lo habia hecho mucho antes de que lo dijeras.. pero seguire intentando haber que onda
 

lenin

XenForoUser
Mensajes
451
Puntuación de reacciones
212
Puntos
43
Sitio web
kpumco.com
País
El Salvador
Versión de XenForo
esta solucionado. lo que pasaba es que yo a la carpeta foro le daba permisos 0777 que no tiene que ser asi si no que permisos 0775
otra cosa el archivo htaccess.txt se sube a la carpeta foro y se cambia por htaccess.
y es lo que no estaba haciendo bien, y por eso el problema....
ya funciona todo como yo quería...
 

lms

Administrador
Mensajes
7.669
Puntuación de reacciones
2.098
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Daba por sentado que lo estabas cambiando por defecto al cambiar los archivos (al .htaccess me refiero) a la carpeta foro.

Mejor que se haya solucionado. Me alegro.

Salud2
 
Estado
Cerrado para nuevas respuestas
Arriba