• ¡Bienvenido a XenFácil!

    Estás viendo el sitio como Invitado. Para poder participar en este sitio

    y obtendrás privilegios adicionales, acceso a otras áreas y mucho mas.

    ¡Es gratis!


    ¿Ya eres miembro? Inicia sesión

Ayuda Problemas Con https

#1
Hola a toda la comunidad de XenFacil
Mi Problema es que yo ultimamente tengo Bastantes Problemas con el Certificado de mi sitio.
Cuando entro solo del dominio entra con http con lo cual dice que no es seguro entonces lo que yo quiero es forzar a que entre Solo y Siempre Por https. Vamos que cuando pongan el dominio sin https se rediriga automaticamente a https Muchisimas Gracias Por La Ayuda.
Saludos !!
 

leinadesp

XenForoUser
#2
Me imagino que lo que te falta es forzar el https:

Sacado de la guía que publicó @lms : https://xenfacil.com/recursos/como-implementar-ssl-para-trafico-seguro-de-http-https.124/
Forzar HTTPS
Una vez instalado el certificado, el paso siguiente es forzar la utilización de HTTPS, de forma que cualquier visitante que esté navegando cualquier URL y utilizando HTTP, se enrute a su equivalente HTTPS.
Si se tiene un servidor Apache, esto se hace agregando lo siguiente en el archivo .htaccess:

RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Dependiendo sel servidor y de la configuración exacta puede preferirse/ser necesaria una variación.
Adviértase que cualquier regla de reescritura personalizada debe estar antes que las reglas de reescritura de XenForo.
 
Gustó a: lms
#3
Es de esperar que esta guía explique todos los pasos necesarios para cambiar una instalación XF de HTTP a HTTPS.
Entonces, por ejemplo, en vez de que la URL del sitio sea XenForo community, será...
Sin permiso para ver el contenido completo de este recurso. :(
 
Arriba