• ¡Bienvenido a XenFácil!

    Estás viendo el sitio como Invitado. Para poder participar en este sitio

    y obtendrás privilegios adicionales, acceso a otras áreas y mucho mas.

    ¡Es gratis!


    ¿Ya eres miembro? Inicia sesión

Tutorial Importar Un Idioma

lms

Administrador
Mensajes
7.743
Puntuación de reacciones
2.158
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Para poder importar un idioma debes acceder al panel de control.

:instrucciones:

Una ver accedido vete a Panel de Control -> appearance -> Languages & Phrases -> Import Language -> Import from uploaded file -> Elige tu archivo XML de idioma y pulsa el botón Import New Language.
Espera que termine de subir y de hacer sus cosas.

Luego vas a Panel de Control -> Appearance -> Abajo, a la derecha, bajo el epígrafe Languages, marca la casilla del idioma recién importado. Te aparecerá arriba una ventana que baja y pone cambios guardados (saved changes). Ya lo tienes en español.

Salud2
 

lms

Administrador
Mensajes
7.743
Puntuación de reacciones
2.158
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Si se te produce un error en al importación, la solución la aporta Descaro:
ya se ha informado al equipo de xenforo, es un bug que para la próxima beta2 quedará subsanado..

por ahora solo existe un parche que corrige el error:

hay que añadir en: library/XenForo/Model/Phrase.php después de la línea 970

este código:

Insertar CODE, HTML o PHP:
$this->compileAllPhrasesInLanguage($languageId);
Salud2
 

DL Gushh_

Miembro
Mensajes
64
Puntuación de reacciones
49
Puntos
18
Sitio web
desload.net
Sres, luego de importar el lenguage y querer modificarlo me aparece el siguiente error

"Parse error: syntax error, unexpected '.' in /home/eq88799/public_html/forum/library/XenForo/Template/Abstract.php(206) : eval()'d code on line 117"

Que podra ser ?
 

descaro

Activo
Mensajes
353
Puntuación de reacciones
129
Puntos
43
saludos DL Gushh :)

ese error, si estas usando la Beta 1, se corrige con el parche que tienes en el post anterior al tuyo, en la nueva versión beta2 parece que se corrigió, por lo que te aconsejo actualices.

de cualquier forma descarga de nuevo el archivo .xml y reintentalo
 
Arriba