• ¡Bienvenido a XenFácil!

    Estás viendo el sitio como Invitado. Para poder participar en este sitio

    y obtendrás privilegios adicionales, acceso a otras áreas y mucho mas.

    ¡Es gratis!


    ¿Ya eres miembro? Inicia sesión

XenPortal Xenporta (portal) de 8wayrun.com

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
Buenas

Acabo de instalar xenportal y tengo un problema, se me ha duplicado el foro.

me explico, ahora cuando entras a la web tienes arriba para seleccionar:

noticias - que es el foro
noticias - que es el portal
foro . que es el foro otra vez

quiero que cuando pongas el link de la web, aparezca el portal y luego tengas el foro para elegir, es decir, que desaparezca el primer noticias.

Dejo el link:

forocojuntas.es

Gracias!


SOLUCIONADO gracias a http://www.xenfacil.com/temas/eliminar-un-inicio-del-index.573/

Ahora lo unico que quiero es que de inicio me aparezca el portal y no el foro y que se eliminte el index.php y el index.php?portal/.

dejo el link y muchisimas gracias por este foro, nos sirve de muchisimo!

foroconjuntas.es
 

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Hoy han publicado una release para 1.2.0 de xenportal. Si tienes la versión 1.1.5, ¿qué versión has instalado?

Además, en la nueva versión, ya no está la opción de poner la página como índice (o portal) desde sus opciones. Hay que hacerlo desde Route Filters (filtros de ruta).

Salud2
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
Hoy han publicado una release para 1.2.0 de xenportal. Si tienes la versión 1.1.5, ¿qué versión has instalado?

Además, en la nueva versión, ya no está la opción de poner la página como índice (o portal) desde sus opciones. Hay que hacerlo desde Route Filters (filtros de ruta).

Salud2


buenas de nuevo lms

he instalado la última versión y xenforo tb lo tengo actualizado.

como hago para que no me aparezca el index, el portal me aparezca de inicio y el foro me aparezca /foro?
con lo de filtros de ruta no me aclaro....


te deje el link por si acaso! Gracias!
 

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Aunque no es necesario, yo tengo instalado el Route Changer (cambiador de rutas) que ménos complicado de usar.

Salud2
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
Perfecto lms.

Con Route Changer, activando Friendly URLs y modificando el renombrando el htaccess.txt por .htaccess todo bien!

Muchas gracias de nuevo!
 

Antich

XenForoUser
Mensajes
154
Puntuación de reacciones
9
Puntos
18
País
España
Versión de XenForo
1.5.6
Página web
Web
A mi al instalar la versión nueva de XenPortal me da el siguiente error:

motoristes.cat dijo:
Server Errorcall_user_func_array() expects parameter 1 to be a valid callback, class 'EWRporta_Option_ForumChooser' does not have a method 'verifyOption'XenForo_Application::handlePhpError()call_user_func_array() in EWRporta/DataWriter/Options.php at line 140EWRporta_DataWriter_Options->_validateOptionValuePreSave() in EWRporta/DataWriter/Options.php at line 71EWRporta_DataWriter_Options->_preSave() in XenForo/DataWriter.php at line 1434XenForo_DataWriter->preSave() in XenForo/DataWriter.php at line 1373XenForo_DataWriter->save() in EWRporta/Model/Options.php at line 86EWRporta_Model_Options->updateOption() in EWRporta/Model/Options.php at line 151EWRporta_Model_Options->importOptionsXml() in EWRporta/Model/Blocks.php at line 231EWRporta_Model_Blocks->installBlockXml() in EWRporta/Model/Blocks.php at line 182EWRporta_Model_Blocks->installBlockXmlFromFile() in EWRporta/Install.php at line 59EWRporta_Install::installCode()call_user_func() in XenForo/Model/AddOn.php at line 215XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 187XenForo_ControllerAdmin_AddOn->actionInstall() in XenForo/FrontController.php at line 337XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134XenForo_FrontController->run() in /homez.727/forosoci/www/admin.php at line 13
 
Última edición por un moderador:

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
EWRporta/Option/ForumChooser es la ruta al archivo que no falla. Esta se encuentra en la de recents Threads y el x5 (creo que también en recents news).
Hay que editar el xml de estos bloques para quitarles la línea que solicita la validación (ya no está presente) e instalar entonces. Te puede ocurrir si tenías alguno de ellos instalado y no has actualizado el bloque o módulo. Pon el nuevo.

Salud2
 

Antich

XenForoUser
Mensajes
154
Puntuación de reacciones
9
Puntos
18
País
España
Versión de XenForo
1.5.6
Página web
Web
EWRporta/Option/ForumChooser es la ruta al archivo que no falla. Esta se encuentra en la de recents Threads y el x5 (creo que también en recents news).
Hay que editar el xml de estos bloques para quitarles la línea que solicita la validación (ya no está presente) e instalar entonces. Te puede ocurrir si tenías alguno de ellos instalado y no has actualizado el bloque o módulo. Pon el nuevo.

Salud2
Recibido, voy a darle una ojeada luego. Merci
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
buenas de nuevo

actualizado a 1.2 ahora no me deja crear temas...os dejo el error

Argument 1 passed to EWRporta_DataWriter_Discussion_Thread::_discussionPostSave() must be an array, none given, called in /home/forocsgo/public_html/library/XenForo/DataWriter/Discussion.php on line 453 and defined
  1. XenForo_Application::handlePhpError() in EWRporta/DataWriter/Discussion/Thread.php at line 5
  2. EWRporta_DataWriter_Discussion_Thread->_discussionPostSave() in XenForo/DataWriter/Discussion.php at line 453
  3. XenForo_DataWriter_Discussion->_postSave() in XenForo/DataWriter.php at line 1397
  4. XenForo_DataWriter->save() in XenForo/ControllerPublic/Thread.php at line 943
  5. XenForo_ControllerPublic_Thread->actionSave() in XenForo/FrontController.php at line 337
  6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  7. XenForo_FrontController->run() in /home/forocsgo/public_html/index.php at line 13
gracias anticipadas lms
 

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Me temo que está usando la versión para XNFORO 1.2.0 de XenPorta y tu no has actualizado a XenForo 1.2.0. O actualizas o deshabilita el xenportal debieras hacer un downgrade del xenportal a una versión comptible con tu versión)

Salud2
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
Me temo que está usando la versión para XNFORO 1.2.0 de XenPorta y tu no has actualizado a XenForo 1.2.0. O actualizas o deshabilita el xenportal debieras hacer un downgrade del xenportal a una versión comptible con tu versión)

Salud2

tengo XenForo 1.2.0, copiado y pegado ahora mismo, que version de xenporta es compatible? tengo instalada la 1.5.9
 

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Esa es en principio la compatible. Las funciones son correctas.

Haz una cosa. Bájate todos los archivos de xenportal y lugo los borras del servidor.
Resube luego SOLO los archivos propios de xenporta (como cuando actualizas). Tras ello, de uno en uno, los bloques o módulos. Vete comprobando como va el tema.

Otra opción es renombrar el directorio de xenportal (en library) y resubir los archivos de la instalación del complemento.

Salud2
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
ok lms

He probado a actualizar sin mas y ha habido un error:

ErrorException: call_user_func_array() expects parameter 1 to be a valid callback, class 'EWRporta_Option_ForumChooser' does not have a method 'verifyOption' -library/EWRporta/DataWriter/Options.php:140

Voy a probar lo que me has dicho y te comento
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
call_user_func_array() expects parameter 1 to be a valid callback, class 'EWRporta_Option_ForumChooser' does not have a method 'verifyOption'

Este error al instalar de nuevo. si, he borrado las celdas de la base de datos.
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
ok lms

He probado a actualizar sin mas y ha habido un error:

ErrorException: call_user_func_array() expects parameter 1 to be a valid callback, class 'EWRporta_Option_ForumChooser' does not have a method 'verifyOption' -library/EWRporta/DataWriter/Options.php:140

Voy a probar lo que me has dicho y te comento

No guarde los archivos que me dijiste!
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
No guarde los archivos que me dijiste!

Siento ser tan pelma, pero soy novato y creo que aportar todo esto igual le viene bien a alguien mas adelante.

He desinstalado xenporta eliminando tambien las celdas de las bases de datos. al final tenia instalando de nuevo tenia un error porque o:

1 - me daba un error con los route filters
2. me daba error por los bloques que tenia antes en mi portal.

He eliminado las rutas y todo lo que tenia en mi host sobre xenporta y ahora ya todo bien.

NUEVO PROBLEMA

Quiero que mi url, foroconjuntas.es, me lleve al portal/ pero no lo consigo...
 

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
Instala el Route changer que va de cine y se entiende muy bien.

Salud2
 

ioneti

XenForoUser
Mensajes
72
Puntuación de reacciones
3
Puntos
8
ya todo bien por fin, he reinstalado todo y ok todo por ahora.

gracias lms

no se si aprovechar aqui para unas duda:

1 Opcion de justificar texto en los nuevos temas
 

lms

Administrador
Mensajes
7.741
Puntuación de reacciones
2.162
Puntos
2.613
Sitio web
xenfacil.com
País
España
Versión de XenForo
2.1.x
PayPal
Donar dinero a este usuario
Página web
Web
ya todo bien por fin, he reinstalado todo y ok todo por ahora.

gracias lms

no se si aprovechar aqui para unas duda:

1 Opcion de justificar texto en los nuevos temas
Complicado. Depende del editor que manejes y del gestor de código BB que manejes. Aún así, es complicado el tenerlo por defecto. Con el gestor de Cedric tienes la opción (como verás aquí).

Salud2
 
Arriba